переустановил сервак и понеслось....

суть такая: стоял проект на PHP5.4.7 жил себе хорошо, жил но тут понадобилось поднять версию до 5.4.12…
вроде все сделал как было, все модули теже, все на те-же местах но в управлении плагинами не отдает контент вообще, передано 0 байт, в логах сервера ошибок нет!
P.S. потом заметил что на страницу /admin/plugins ругается Failed to load resource: the server responded with a status of 404 (Not Found) а по логу сервера и в консоли браузера 200 (видимо на какой-то обязательный файл ругается типа favicon)
В остальном все более-менее ажурно…
а и aceadminpanel перестала работать вообще…

12 комментариев

avatar
права на файлы провеьте:
1.0.3
2.0.1
avatar
до глобального обновления все прекрасно работало… оно и сейчас вроде как работает, ошибок нет, отдает код 200, но картинки тоже нет, то есть пустой файл… уж голову сломал что там поломалось…
avatar
Ради интереса набрал в Яндексе «Failed to load resource: the server responded with a status of 404 (Not Found)» и судя по результатам это какая-то проблема с путями, плагина ЧПУ случаем не установлено?
avatar
Да это стандартная ошибка вэбсервера… тут я уже разобрался что он ругается на favicon а вот на страницу плагинов — это вопрос…
то что там XGE стоит — ни о чем не говорит, а вот mod_rewrite может глючить но сервак то 200 отдает — то есть все хорошо, былаб ошибка — дал бы 500 (но ее нет)
avatar
*ЧПУ
avatar
Пойдешь в ЛС? Нужно объединить усилия.
avatar
ну, не на сеновал и без кузнеца — пойду, чож не пойти то )))
avatar
Такая-же проблема.
avatar
пока нашел, что залипает на вызове функции Plugin_GetList файл /classes/actions/ActionAdmin.class.php
строка примерно 159
$aPlugins=$this->Plugin_GetList(array('order'=>'name'));
Хотя саму функцию найти чот не получается :-(((
avatar
Тут она engine\modules\plugin\Plugin.class.php
avatar
А Вы уверены что ошибка в модуле?
Перед обновлением нужно было прочитать в доке по php (если только его обновляли, а веб сервер не трогали) какие директивы меняются.
И вообще:
на PHP5.4.7 жил себе хорошо, жил но тут понадобилось поднять версию до 5.4.12…
Смены мажора не было. Скорее всего это не в php дело.
avatar
проблема решена… simplexml не хватало, на него и ругалось
если что php5-xml и php5-simplexml — это разные модули
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.