+20.99
333 читателя, 269 топиков

Баг или фича?

Господа, или мне кажется, или это очень странный баг. Судите сами, вот страница активности:
Sys "добавил новый топик"
Как видите, активность совсем недавняя. Смотрим: пользователь sys добавил новый топик. Вот ссылка на этот топик.
Дата топика (!)
Оказывается, дата публикации топика — 4 ноября 2009, 05:55. Но он показывается, как недавно созданный. Может, он был отредактирован пользователем sys ? Нет, заходим на его профиль: последнее посещение — 04 октября 2010, 20:45.

Что это было?

P.S. Есть подозрение, что это добавили рекламу в топик.

Не работает Ctrl+Enter в TinyMCE

Здравствуйте.
Интересный факт: поддержка Ctrl+Enter УЖЕ есть в TinyMCE:

\engine\lib\internal\template\js\settings.js:125
setup : function(ed) {
				// Display an alert onclick
				ed.onKeyPress.add(function(ed, e) {
					key = e.keyCode || e.which;
					if(e.ctrlKey && (key == 13)) {
						$('#comment-button-submit').click();
						return false;
					}
				});
			}


Но он не работает! При этом, кнопка добавления имеет правильный id, всё остальное сходится. Но при этом — нулевой результат. Что делать — ума не приложу.
LS 1.0.3, проверил баг на 2-х сайтах.

UPDATE:
Замена ctrlKey на shiftKey работает (с шифтом всё нормально). Почему беда с Ctrl — не понимаю.
На всякий случай уточню: клавиатуры тоже разные пробовал) И не только я эту проблему вижу.

Слетают логин-пароль при переходе в топик?!

При переходе в топик «читать дальше» слетает логин, если попытаться авторизироваться окно логина зависает, возвращаюсь на главную авторизация на месте…
Находил здесь несколько тем с проблемой авторизации но ничего не помогло может быть у кого-нибудь есть свежии мысли, что за ерунда такая и как с этим бороться…?

Update:
Где можно помощи попросить что бы наладить эту хрень? не работает хоть убейся ( перепробывал куеву тучу способов, 52 раза переустанавливал ночь не спал и все без успешно…
Плагинов нет
Fresh install

[РЕШЕНО]


Проблема была в хостинге, из слов тех поддержке " на сервере была замечена CPU перегрузка и ваш аккаунт был ограничен из чего и возникли проблемы с авторизацией"

Ошибка установки

1. Установка LiveStreet Шаг 2 / 4
Всё нормально!
2. Установка LiveStreet Шаг 3 / 4
Заполняю поля, нажимаю «Далее» и меня перекидывает на предыдущую страницу.
3. Установка LiveStreet Шаг 2 / 4

Хостинг reg.ru
Параллельно, на всех страницах установки висят ошибки:

вверху:

Warning: session_start() [function.session-start]: open(/tmp/u0043972/sess_54ea33bd9cd23d39223b423990fc445c, O_RDWR) failed: Permission denied (13) in /var/www/u0043972/data/www/адрессайта/install/index.php on line 1920

Warning: session_start() [function.session-start]: Cannot send session cookie — headers already sent by (output started at /var/www/u0043972/data/www/адрессайта/install/index.php:1920) in /var/www/u0043972/data/www/адрессайта/install/index.php on line 1920

Warning: session_start() [function.session-start]: Cannot send session cache limiter — headers already sent (output started at /var/www/u0043972/data/www/адрессайта/install/index.php:1920) in /var/www/u0043972/data/www/адрессайта/install/index.php on line 1920

и внизу:

Warning: Unknown: open(/tmp/u0043972/sess_54ea33bd9cd23d39223b423990fc445c, O_RDWR) failed: Permission denied (13) in Unknown on line 0

Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/tmp/u0043972) in Unknown on line 0

Подобная проблема была здесь, но рецепты не помогли. Возможно, чего-то не понял.

Периодически отваливается авторизация

Собственно, вся проблема описана в заголовке. Ни с того ни с сего юзер оказывается разлогиненным, причем при попытке тут же войти, первые 5-15 секунд будет ошибка «неверный логин/пароль», потом пускает.

Раньше такая фигня была минимум раз в полчаса, поставил плагин Remember me, вылеты сократились до 1-2 раз в день.

"Люди" и "Друзья" - непонятен алгоритм вывода в ленте

Здравствуйте.
Вот, собственно, проблема


Непонятно, почему в одном случае люди добавляются в «друзья» в меню ленты, а в другом — просто в «люди». Притом, что все вышеотмеченные добавлены в друзья (взаимно).

Ошибка в вычислении кол-ва топиков при удалении блога

ЛС 1.0.3
Дело в том что сам блог удаляется без проблем, даже если в нем есть топики… и тут возникает проблема с «активностью», тк топики есть, а блога нету.
По задумке при удалении движе проверяет наличие топиков в блоге и если он пуст то удаляет.
Загвоздка оказалась в GetTopicsByBlogId($sBlogId)

ActionBlog.class.php
$aTopics =  $this->Topic_GetTopicsByBlogId($sBlogId);


Она получает массив топиков и далее идут как раз те проверки на наличие топиков в блоге простым
count($aTopics)

И здесь кроется камень преткновения… У функции GetTopicsByBlogId есть куча параметров, но третий передает количество… и по умолчанию там стоит 0 )))
В итоге мы запрашиваем список блогов и в максимальном количестве в 0 шт, понятно почему тогда проверки не проходят.
Решение:
Можно либо в файле ActionBlog.class.php передать нужные параметры
$aTopics =  $this->Topic_GetTopicsByBlogId($sBlogId,0,1);    //нам конкретика не нужна, главное есть топики или нет.


либо в модулях Topic.class указать параметр по умолчанию 1 ($iPerPage=1)
public function GetTopicsByBlogId($iBlogId,$iPage=0,$iPerPage=1,$aAllowData=array(),$bIdsOnly=true) {

Ошибки при попытке зайти в настройки профиля

Добрый день. Внезапно образовалась следующая ошибка при попытке зайти в настройки профиля (мойсайт.ру/settings/profile/):

Fatal error: Uncaught exception 'Exception' with message 'Undefined method module: MenuSettingsTpl' in /var/www/webroot/ROOT/engine/classes/Engine.class.php:604 Stack trace: #0 /var/www/webroot/ROOT/engine/classes/Engine.class.php(531): Engine->GetModule('MenuSettingsTpl') #1 /var/www/webroot/ROOT/engine/classes/Hook.class.php(71): Engine->_CallModule('MenuSettingsTpl', Array) #2 [internal function]: Hook->__call('MenuSettingsTpl', Array) #3 [internal function]: PluginPostingingroups_HookMain->MenuSettingsTpl(Array) #4 /var/www/webroot/ROOT/engine/modules/hook/Hook.class.php(292): call_user_func_array(Array, Array) #5 /var/www/webroot/ROOT/engine/modules/hook/Hook.class.php(244): ModuleHook->RunType(Array, Array) #6 [internal function]: ModuleHook->Run('template_menu_s...', Array) #7 /var/www/webroot/ROOT/engine/classes/Engine.class.php(558): call_user_func_array(Array, Array) #8 /var/www/webroot/ROOT/engine/classes/Engine.class.php(667): Engine->_CallModule('Hook_Run', Array) #9 /var/www/webroot/ROOT/engine/modules/viewe in /var/www/webroot/ROOT/engine/classes/Engine.class.php on line 604


Подскажите пожалуйста что это может быть и как это поправить. Заранее весьма благодарен!

UPD

Отключение плагина «Публикация топиков в группы» решило задачу. Сейчас буду пробовать обновленную его версию.

Населенные пункты Казахстана.

В движке почти все населенны пункты старые. Области, имена и так далее.

Джезказганской области уже нету с 1996-1997 года(точно не помню).

Вот таких куча примеров показать могу. Предлагаю исправить.