-2.14
Рейтинг
0.28
Сила

Пропали превьюхи после установки aceadmin

Дано:
Версия LiveStreet: 1.0.1
aceAdminPanel: v.2.0.388
Category: v.0.2
Flow: v.1.2.0
Main preview topic: v.1.1
Редкатирование даты публикации: v.0.1.1
Template Social: v.3.1
ТОП Топики в блоге: v.0.1

Сразу после установки плагина админки превью были на месте, но после редактирования нескольких постов у них пропали превью. Запустил регенерацию и тут пропали уже все превью.
После отключения плагина Aceadmin и новой регенерации ничего не изменилось.
Куда смотреть, в чем может быть проблема?

Раскрутка закрытого сообщества, раздача&розыгрыш инвайтов

Бренсон классный.Занялся раскруткой полностью закрытого сообщества, т.е. регистрация по инвайтам и закрытое содержание сайта. Не буду распространяться о причинах такого решения, тема не об этом. Тема о том, что из-за закрытости, совершенно не будет работать обычный способ продвижения, SEO, нужно что-то другое. Где-то в комментариях я видел совет по набору участников в сообщество через ВК, искать людей через группы и интересы, предлагать им вступить в сообщество. Идея интересная, в ВК сейчас весь рунет есть, найти можно кого угодно, но, из-за огромного количества спама отношение к рекламным письмам у людей резко негативное. К тому же, мне нужен определенный тип людей с определенными интересами. Хочу сделать упор на качество, а не на количество.

Какие варианты привлечения людей я надумал:

1. Поиск статей, постов, комментариев в блогах, на форумах и соц. сетях по своей тематике и отправка инвайта авторам текстов. Долго, затратно по времени, должно быть эффективно, если вместе с инвайтом написать письмо с восторженным отзывом о статье&комментарии.

Читать дальше →

Ошибка при добавлении топика

Все работало несколько дней. Сегодня не смог добавить пост. Ничего за это время не менялос. Совершенно не могу понять с чего вдруг.

Fatal error: Call to a member function getPreviewImage() on a non-object in /var/www/xekcc/data/www/********.com/plugins/mainpreview/classes/modules/main/Main.class.php on line 329

Топики появляются на главной, без превьюшек, но ведут в никуда:
«Ошибка: 404

К сожалению, такой страницы не существует. Вероятно, она была удалена с сервера, либо ее здесь никогда не было.»

329 строка —
$this->Image_RemoveFile($this->Image_GetServerPath($oTopic->getPreviewImage()));


/**
	 * Удаление превью у топика
	 *
	 * @param $oTopic
	 */
	public function DeleteTopic($oTopic) {
		$this->Image_RemoveFile($this->Image_GetServerPath($oTopic->getPreviewImage()));
		$aSizes=Config::Get('plugin.mainpreview.size_images_preview');
		// Удаляем все сгенерированные миниатюры основываясь на данных из конфига.
		foreach ($aSizes as $aSize) {
			$sSize = $aSize['w'];
			if ($aSize['crop']) {
				$sSize .= 'crop';
			}
			$this->Image_RemoveFile($this->Image_GetServerPath($oTopic->getPreviewImageWebPath($sSize)));
		}
		$oTopic->setPreviewImage(null);
		$oTopic->setPreviewImageOriginalWidth(null);
		$oTopic->setPreviewImageOriginalHeight(null);
		$oTopic->setPreviewImageIsAuto(false);
	}


up// снова все работает. Что это было?

Не удаляются теги

Стояла версия LS 0.3.x, точно не помню. Сайт был в длительном простое, поэтому за пару месяцев накопилось много спамных топиков с тегами. Топики удалил, теги из списка пропали.

Недавно обновился до версии 0.4.2, и теги снова появились в сайдбаре. В админпанеле возможности удалить теги нет. Попробовал удалить их прямо из базы, таблица prefix_topic_tag. Удалил, ничего не изменилось.

Почему теги до сих пор отображаются, и как их удалить?