ссылка на вставку видео tinyMCE

Доброго времени всем!

Долго шарился в просторах интернета, чтобы найти более менее удобный для ОБЫЧНЫХ пользователей редактор. Пытался интегрировать tinyMCE 4 и ckeditor старый. Первый полу рабочий оказался, а второй еще старее стандартного.
На ЛС сайте так и не нашел не одного решения на самые актуальные проблема с редактором. Как так?? 2017 год заканчивается как бы.
В общем интегрировать новый редактор желание пропало. Прошу помощи в следующем:
Как сменить тип ссылки с HTML на обычный URL(с адресной строки) при вставке видео в стандартном tinyMCE на LS 1.0.3?
Запустил тестом сайт, и 40% пользователей понятия не имеют что такое HTML ссылка с видео.

Заранее благодарю.

Код:

public function VideoParser($sText) {
		/**
		 * youtube.com
		 */
		$sText = preg_replace('/<video>http:\/\/(?:www\.|)youtube\.com\/watch\?v=([a-zA-Z0-9_\-]+)(&.+)?<\/video>/Ui', '<iframe width="560" height="315" src="http://www.youtube.com/embed/$1" frameborder="0" allowfullscreen></iframe>', $sText);

Помогите определиться с выбором

Доброго времени суток уважаемое сообщество!
Есть у меня довольно большое тематическое сообщество в социальной сети, но там становиться «тесновато и не удобно» и вот назрела необходимость создать сайт. В своем выборе остановился на Livestreet.
Учитывая то, что знания в области создания сайтов у меня поверхностные помогите определиться с версией. Я понимания что 2.0 свежее, но под нее мало адаптированных плагинов. Собственно вопрос в следующем — могу ли использовать для нового сайта версию 1.0.3 или же этого делать не желательно?

Условие для отображения в немобильном шаблоне

Здравствуйте Господа!
Задача — скрывать часть кода (в плагине) если у пользователя включен мобильный шаблон.
{if шаблон НЕмобильный}
Здесь мой код для отображения в НЕмобильном шаблоне
{/if}


Спасибо.

Отключение персональных блогов на ls 1.0.3 (F.A.Q)

Я сам новичок в ls, двиг очень понравился, но после установки кое-что пришлось подпиливать под себя!

И так, к делу! В этом посте я расскажу как отключить «Персональные блоги» на ls 1.0.3

Читать дальше →

Upgrade 0.4.2 до 1.0.3

Всем привет!
Есть сайт на ls v0.4.2(админка 1.4.183), с небольшим количеством плагинов, хочу обновиться до 1.0.3
Можно ли безболезненно, «автоматически», обновиться, или потребуются танцы с бубуном? Работоспособность плагинов не важна, главное чтоб всё содержимое не пострадало!
Есть ли мануал по апгрейду?

Вопрос кармы ?

Добрый день Livestreet!
у меня вопрос по карме!
как сделать подобную карму как на сайте live-cs.ru?

карма:
+0,15095 — убран — + у пользователей

карма начисляется за комментарии, дискуссии, статьи и т.д!

прошу помощь мне в данном вопросе? версия движка 1.0.3

Ошибка при обновлении движка на версию 1.0.3

Добрый вечер. Знающие люди, подскажите пожалуйста, в чем причина возникновения следующей ошибки:
после обновления движка с версии 4.0.2 до 1.0.3 (через 0.5.1) при открытии ссылки site.ru/people/ появляется следующая ошибка:
SQL Error: Table 'b22123_doma.prefix_geo_target' doesn't exist at /home/u22123/doma-kubaniru/livestreet103/classes/modules/geo/mapper/Geo.mapper.class.php line 79
Array ( [code] => 1146 [message] => Table 'b22123_doma.prefix_geo_target' doesn't exist [query] => SELECT SQL_CALC_FOUND_ROWS * FROM prefix_geo_target WHERE 1 = 1 AND target_type = 'user' AND target_id IN ( '17', '27', '15', '26', '52', '25', '53', '47', '48', '69', '55', '32', '51', '37', '80' ) ORDER BY target_id DESC LIMIT 0, 15; [context] => /home/u22123/doma-kubaniru/livestreet103/classes/modules/geo/mapper/Geo.mapper.class.php line 79 )

Немного подробностей:
Сначала обновил до версии 0.5.1 — всё нормально. Потом удалил с сервера все файлы (кроме аплод) и залил новые файлы движка 1.0.3. Зашел на site.ru/install/ и тут сразу открылся шаг 4/4 мастера установки с поздравлением с успешной установкой сайта. Это меня смутило и я перешел на несколько шагов назад в мастере установки и поставил галочку «конвертировать базу 0.5.1 в 1.0.3».
Могло ли это быть причиной возникновения описанной выше ошибки?

Релиз LiveStreet 1.0.3

Сообщаем о выходе новой версии LS 1.0.3. Версия носит багфиксный характер.
Были закрыты две XSS уязвимости(спасибо HiMiC и PSNet ) и исправлено раскрытие директории в сессиях(еще раз спасибо PSNet ).

Обновленный дистрибутив уже доступен для загрузки — livestreetcms.ru/download/
Для закрытия этих багов для версий 1.0.2, 0.5.1 и 0.4.2 достаточно скачать этот патч и залить его поверх вашей версии LS.

Важное замечание! Настоятельно рекомендуем обновиться с версий 0.5 и 0.4 до актуальной 1.0.3. Т.к. помимо исправлений этого патча старые версии содержать множество других бед, в том числе и потенциальные уязвимости.

Изменения коснулись 4-х файлов:
config/jevix.php
engine/lib/external/Jevix/jevix.class.php
engine/lib/external/swfupload/swfupload.swf
engine/modules/session/Session.class.php

Подробнее можно посмотреть на гитхабе — github.com/livestreet/livestreet/commit/83c15587388dec02f8b97eac8a0d809a3233702c